We are experiencing problems with Cloudflare.
Incident Report for CrossBrowserTesting
Resolved
Cloudflare's fix is being implemented across their service range. We have confirmed our app is functional.
Posted Jun 21, 2022 - 02:51 CDT
Monitoring
Cloudflare has identified a fix and is being implemented. Access to CrossBrowserTesting has been restored. We are continuing to monitor the situation and ensure site reliability.
Posted Jun 21, 2022 - 02:14 CDT
Investigating
Cloudflare is experiencing issues that are impacting multiple services across the internet, including Crossbrowsertesting.com. Read more about cloudflare issue at https://www.cloudflarestatus.com/. We are monitoring the situation.
Posted Jun 21, 2022 - 02:01 CDT
This incident affected: Crossbrowsertesting App, Selenium Test, and Screenshot Test.