Platform Outage
Incident Report for CrossBrowserTesting
Resolved
Root cause was discovered & addressed. Service is now restored & operational.
Posted Oct 02, 2020 - 13:04 CDT
Investigating
We are currently investigating the service degradation & outage.
Posted Oct 02, 2020 - 10:47 CDT
This incident affected: Crossbrowsertesting App, Live Test, Selenium Test, and Screenshot Test.