Service outage
Incident Report for CrossBrowserTesting
Resolved
Service has been restored.
Posted Oct 17, 2022 - 19:02 CDT
Investigating
We are investigating an issue currently impacting all test components / platforms.
Posted Oct 17, 2022 - 17:49 CDT
This incident affected: Crossbrowsertesting App, Selenium Test, and Screenshot Test.