Partial service degradation
Incident Report for CrossBrowserTesting
Resolved
The incident has been resolved
Posted Jun 22, 2022 - 10:11 CDT
Investigating
We are currently investigating the situation
Posted Jun 22, 2022 - 09:52 CDT
This incident affected: Selenium Test.