Degraded Performance on CrossBrowser Platform
Incident Report for CrossBrowserTesting
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 05:24 CST
Monitoring
At approximately 4:19AM Central (10:19AM UTC) on November 5, 2019, the CrossBrowserTesting team was made aware of a performance degradation on the platform. Upon investigation, it was discovered that a load balancing mechanism had become partially degraded, causing extreme load on certain parts of the infrastructure. This load balancing mechanism has been fixed, and load throughout the system is returning to normal. We are continuing to monitor the situation to ensure proper platform operation.
Posted Nov 05, 2019 - 05:01 CST
This incident affected: Live Test, Selenium Test, and Screenshot Test.