We are experiencing problems with our system.
Incident Report for CrossBrowserTesting
Resolved
This incident has been resolved.
Posted Aug 19, 2022 - 11:35 CDT
Update
We are continuing to investigate this issue.
Posted Aug 19, 2022 - 11:35 CDT
Investigating
We are currently investigating this issue.
Posted Aug 19, 2022 - 10:54 CDT
This incident affected: Crossbrowsertesting App, Selenium Test, and Screenshot Test.