Maintenance/Service Upgrade Window
Incident Report for CrossBrowserTesting
Resolved
The maintenance window has ended and the site is now available.
Posted Apr 20, 2023 - 19:11 CDT
Monitoring
On April 20, we will be performing scheduled maintenance on the CrossBrowserTesting platform. The window begins at 10:00 CDT.

While you’re here! Don’t forget that CrossBrowserTesting is shutting down on July 31st. When service resumes, be sure your account owner logs in to easily copy your current account settings over to BitBar so you can continue to test on the latest browsers and devices.
Posted Apr 20, 2023 - 10:05 CDT
This incident affected: Crossbrowsertesting App, Selenium Test, and Screenshot Test.