Performance Degradation
Incident Report for CrossBrowserTesting
Resolved
This incident has been resolved.
Posted Jan 23, 2020 - 12:55 CST
Monitoring
We have taken steps to resolve the issue and are currently monitoring.
Posted Jan 23, 2020 - 12:41 CST
Investigating
We are currently investigating slowness in the CrossBrowserTesting platform.
Posted Jan 23, 2020 - 12:06 CST
This incident affected: Crossbrowsertesting App, Live Test, Selenium Test, and Screenshot Test.