Degraded performance getting to CrossBrowserTesting.com
Incident Report for CrossBrowserTesting
Resolved
This incident has been resolved.
Posted May 17, 2021 - 07:38 CDT
Monitoring
A downstream internet provider from our data center is still having intermittent issues. We implemented some work arounds and are monitoring the situation.
Posted May 14, 2021 - 12:41 CDT
Investigating
We are currently investigating the issue with our hosting facility.
Posted May 13, 2021 - 09:15 CDT
This incident affected: Crossbrowsertesting App, Live Test, Selenium Test, and Screenshot Test.